A 401 error is received when validating the VCF Automation integration in VCF Operations.
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A 401 error is received when validating the VCF Automation integration in VCF Operations.

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Article ID: 435939

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Updated On:

Products

VCF Operations

Issue/Introduction

  • During configuration of the VCF Automation adapter, a '401' error is received in the UI after clicking the 'Validate Connection' button.
  • In VCF Automation, the Organisation portal overview tab shows the error 'Unable to fetch utilisation metrics' 
  • Using the 'Admin' provider credentials for the integration results in a successful validation.

Environment

VCF Operations 9.0.x

VCF Automation 9.0.x

Cause

This issue occurs because the existing credential or token being used does not meet the necessary requirements and lacks the appropriate permissions to successfully authenticate with the provider portal.

Resolution

To resolve this issue, a service account with the proper permissions and use it to configure the integration. The two steps involved in this are detailed below;

  1. Create a new service account in the provider portal as per below;
  2. Grant the newly created service account access, as per the document below;
  3. Reconfigure the VCF Automation adapter in VCF Operations, using the new service account as the credentials.