HAグループの「SUSPENDED」状態が原因で、HCX MONの有効化失敗とL2拡張機能の削除に問題が発生する
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HAグループの「SUSPENDED」状態が原因で、HCX MONの有効化失敗とL2拡張機能の削除に問題が発生する

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Article ID: 435872

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VMware HCX

Issue/Introduction

免責事項:これは英文の記事「HCX MON Enablement Failure and L2 Extension Removal Issues Due to HA Group "SUSPENDED" State」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

VMware HCX を使用したネットワーク移行作業中に、MON を有効にできない、またはネットワーク拡張機能を削除できないといった状況が発生する場合があります。
ネットワークが安定しているように見えても、HCX Manager の GUI またはログには、操作が初期段階で失敗したことが示されます。

  • 特定のセグメントで MON を有効にできなかった。
  • L2 拡張機能の拡張解除/削除ができず、タスクが即座に失敗します。
  • HCX Manager の /common/admin/logs ログに以下のようなエラーメッセージが記録されています。
    <timestamp> UTC [NetworkStretchService_SvcThread-11514, j: e3b6b3d1, , TxId: <uuid>] WARN  c.v.v.h.n.i.AbstractJobInt- Exception in NetworkStretchJobs:EnablePRForExtendedNetworkHAWorkflow. Reason : HA group hagroup-<group-uuid> is not in GROUPED state: groupState=SUSPENDED, statusMessage=

    <timestamp> UTC [NetworkStretchService_SvcThread-11518, j: 69b2a7e7, , TxId: <uuid>] WARN  c.v.v.h.n.i.AbstractJobInt- Exception in NetworkStretchJobs:DisablePRForExtendedNetworkHAWorkflow. Reason : HA group not in valid state
  • HCX Interconnect UI ではHAステータスが「HEALTHY」と表示されますが、内部 DB では「SUSPENDED」と認識されるという不一致が発生します。

Environment

VMware HCX

Cause

  • 主な原因は、NE 機器の HA グループが「サスペンド」状態に入り、その状態が継続することです。
  • 初期接続障害:以前の構成変更(MON の有効化/無効化など)中に、HCX Manager が vCenter Server への接続または DNS を失いました。
  • 古い状態: 状態遷移中に接続が切断されたため、HA グループの「メンテナンス モード」(SUSPENDED) はロールバックまたは正常に完了しませんでした。
  • データベースの不整合:HCX Manager データベースは、構成の破損を防ぐために内部的に「SUSPENDED」状態を維持します。
  • この状態が続く限り、HCX マネージャーは安定性を確保するために、その特定のネットワーク拡張機能に対するそれ以上の変更をブロックします。

Resolution

状態の不整合を解消し、その後のネットワーク操作を可能にするには、以下の手順に従ってください。

  • 基盤となる接続性を復元する

HCX Manager(コネクタとクラウドの両方)が、それぞれの vCenter Server の FQDN を常に解決し、管理 IP にアクセスできることを確認してください。
DNS
サーバー自体が移行または切り替え対象のセグメントにある場合は、一時的な静的ホストエントリまたは代替 DNS パスが利用可能であることを確認してください。

  • HA状態の同期

HCX Manager にアプライアンスの実際の状態を認識させるよう試みる:

  • Navigate to Interconnect > Service Mesh > View Appliances.
  • 「Management」タブに移動してください。
  • 「RECOVER」または「FORCE SYNC」ボタンが表示されている場合は、それをクリックして状態を同期してください。

 

  • HCX Managerサービスを再起動してください。

UIボタンがグレー表示されている場合、または状態が「保留中」のままの場合:





  • HCX Managerアプライアンスまたはapp-engineサービスを再起動してください。

これにより、管理対象エンティティの再検証が実行され、多くの場合、古いデータベースフラグがクリアされます。
アプリエンジンサービスの再起動手順については、以下の手順を参照してください。

  • HCX マネージャー/コネクタに SSH 接続する
  • admin」の認証情報を使用して HCX Connector または Cloud Manager に SSH 接続し、ユーザーを「root」に変更します。
  • 以下の手順に従ってサービスを再起動してください。
            systemctl restart app-engine

  • 強制拡張解除(最終オプション)
    L2 拡張機能を削除する必要があり、HA グループが停止したままの場合は、強制拡張解除オプションを使用します。
    HCX UI --> Network Extension --> 該当するネットワーク拡張機能を選択し、以下に示すように強制拡張解除オプションを選択します。



それでも問題が解決しない場合は、Broadcomのサポートケースを開いてください。KB# 142884を参照してください。