VM fails to power on with the error "File system specific implementation of GetPageRef[file] failed" and Snapshot consolidation fails with Error "The specified feature is not supported by this version".
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VM fails to power on with the error "File system specific implementation of GetPageRef[file] failed" and Snapshot consolidation fails with Error "The specified feature is not supported by this version".

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Article ID: 435869

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • A virtual machine fails to power on and reports the error: "File system specific implementation of GetPageRef[file] failed". Additionally, snapshot consolidation fails with the error: "The specified feature is not supported by this version (24)". These errors typically indicate missing snapshot metadata or an inconsistent snapshot chain.

  • The errors are reported in /<DATASTORE_UUID>/<VM_FOLDER>/<VM_NAME>/vmware.log and  /var/run/log/hostd.log .

Log Path : /<DATASTORE_UUID>/<VM_FOLDER>/<VM_NAME>/vmware.log

YYYY-MM-DDTHH:MM:SS.ZZZZ In(05) worker-XXXXXXXX - DISKLIB-LIB:
Failed to open '/vmfs/volumes/<DATASTORE_UUID>/<VM_FOLDER>/<VM_NAME>-000001.vmdk'
with flags 0xa. The specified feature is not supported by this version (24).

YYYY-MM-DDTHH:MM:SS.ZZZZ Er(02) worker-XXXXXXXX - DISK:
Cannot open disk '/vmfs/volumes/<DATASTORE_UUID>/<VM_FOLDER>/<VM_NAME>-000001.vmdk':
The specified feature is not supported by this version (24).

YYYY-MM-DDTHH:MM:SS.ZZZZ In(05) vmx - Disk GetDigestDiskCount: numDigestDisks = 0

YYYY-MM-DDTHH:MM:SS.ZZZZ In(05) vmx - DISK: Opening disks took 48271 ms.

YYYY-MM-DDTHH:MM:SS.ZZZZ In(05) vmx - Module 'Disk' power on failed.

YYYY-MM-DDTHH:MM:SS.ZZZZ  worker-#### - DISKLIB-VMFS  : "//vmfs/volumes/<DATASTORE_UUID>/<VM_FOLDER>/<VM_NAME>-000001.vmdk" : failed to open (The specified feature is not supported by this version): Error checking sparse file header. Type 19

Log Path : /var/run/log/hostd.log

YYYY-MM-DDTHH:MM:SS.ZZZZ  In(...) Hostd[...] [Originator@... sub=Libs opID=... user=<user>] 
OBJLIB-FILEBE : FileBEQueue: could not queue the operation on 
'/vmfs/volumes/<datastore-id>/<vm-name>/<vm-name>-000001-sesparse.vmdk' : Resource temporarily unavailable

YYYY-MM-DDTHH:MM:SS.ZZZZ  In(...) Hostd[...] [Originator@... sub=DiskLib opID=... user=<user>] 
DISKLIB-VMFS : "/vmfs/volumes/<datastore-id>/<vm-name>/<vm-name>-000001-sesparse.vmdk" : 
failed to open (The specified feature is not supported by this version): 
Error checking sparse file header

YYYY-MM-DDTHH:MM:SS.ZZZZ  Er(...) Hostd[...] [Originator@... sub=DiskLib opID=... user=<user>] 
DISKLIB-LINK : DiskLinkOpen: Failed to open 
'/vmfs/volumes/<datastore-id>/<vm-name>/<vm-name>-000001.vmdk': 
The specified feature is not supported by this version

 

Environment

vSphere ESXI 8.0

Cause

  • vmsd does not contain any snapshot history information, It is expected that snapshot consolidation failed.

cat /<DATASTORE_UUID>/<VM_FOLDER>/<VM_NAME>/VM_Name. vmsd

.encoding = "UTF-8"

snapshot. lastUID = "1"

snapshot.needConsolidate = "TRUE"

  • The virtual machine disk chain is corrupted and cannot be recovered through standard methods. The absence of snapshot metadata in the .vmsd file, along with the GetPageRef[file] failure, indicates a break in the underlying disk descriptor.

Resolution

(1)Solution 1: Clone VM (recommended)

Use a clone instead of an existing VM. Cloned VM not only backs up the data in the original VM, but also forces snapshot consolidation on original VM. After cloning the VM, turn on the cloned VM with the NIC disconnected and see if the services inside can run properly.

(2)Solution 2: Manual Consolidation Snapshot

If the clone fails in the snapshot session, the disk can only be cloned manually

Manually clone the vmdk disk of the VM using vmkfstools. ( VMs need to be shut down)

Use the command 
vmkfstools -i <source file vmdk>.vmdk <DESTINATION VMDK FILE>.vmdk -d thin -a buslogic
to manually clone the vmdk disk for the VM . for detail please see Cloning a Virtual Disk from Snapshots
After cloning the disk, if the ctk file still exists, you can first go to the vmdk descriptor file and comment out the ctk option.
Create a new virtual machine with the same configuration as the original virtual machine.

(3)Solution 3:  Restore VM

Restore VM using backup software. then save and import the current data into the restored VM for data consistency.

(4)Solution 4: waiting for backup software to perform the task again.

In some situations, third-party backup software consolidates snapshots automatically when performing backup tasks again. We need to observe the VM folder to confirm.

If the above 4 solutions cannot be solved, you have to rebuild a new vCenter Server Appliance.

Additional Information