User Role Permissions Not Working
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User Role Permissions Not Working

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Article ID: 435855

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Updated On:

Products

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Issue/Introduction

We are trying to create user role to view and edit agent, server events. Based upon the below documentation we need to provide edit access for "Agent Management" under "Server Management" tab.

https://techdocs.broadcom.com/us/en/symantec-security-software/information-security/data-loss-prevention/25-1/managing-the-enforce-server/managing-roles-and-users/configuring-roles.html

Currently adding "Agent Management" is not granting access to "Agent" or "Server and Detector" events

Environment

DLP 25.1

Cause

Requires Code update, concern is resolved in DLP 26.1

Resolution

Until you are able to upgrade to DLP 26.1 the following workaround can resolve the concern on DLP 25.1

On the Enforce Server:

  1. Navigate to \Program Files\Symantec\DataLossPrevention\EnforceServer\25.1.00000\Protect\config
  2. Open Enforce.properties
  3. Add the following line to the end of the file:

    com.vontu.manager.enable.legacy.agentevent.report=true

  4. Save your change.
  5. Restart services on the Enforce Server
  6. Log into the Enforce Console as a user that only has 'edit access for agent management' rights (No Incident view). Navigate to System > Agents Events. The page should load successfully.