Login fails in VCF Automation 9.x due to User or Group name case sensitivity
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Login fails in VCF Automation 9.x due to User or Group name case sensitivity

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Article ID: 435791

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Updated On:

Products

VCF Automation

Issue/Introduction

  • When attempting to log in to VCF Automation using VMware Identity Broker (vIDB), the authentication fails if there is a case-mismatch between the identity source and the application.

  • Users or groups (e.g., @example.com) fail to authenticate if the corresponding record in VCF Automation is defined with different casing (e.g., @Example.com).

Environment

VCF Automation 9.x

VMware Identity Broker (vIDB) 9.x

Cause

VCF Automation 9.x requires an exact case-sensitive match for all identity attributes.

Resolution

You must ensure that user and group names in VCF Automation 9.x are an exact, case-sensitive match for the names configured in vIDB or your third-party Identity Provider.

If a group was previously added with incorrect casing, perform the following:

  1. Remove the existing group from VCF Automation.

    • To delete a user, follow the steps outlined here: Delete Users.

  2. Re-add the user or group with the correct casing:

Additional Information

A long-term solution that allows for importing users and groups via a search function—eliminating the need for exact case matching—is tentatively planned for a future release VCF Automation 9.2