After planned failover, all the vm has WARNING "The object 'vim.Task:########-####-####-####-############:dr.recovery.RecoveryManager.powerOffVm###' has already been deleted or has not been completely created"
search cancel

After planned failover, all the vm has WARNING "The object 'vim.Task:########-####-####-####-############:dr.recovery.RecoveryManager.powerOffVm###' has already been deleted or has not been completely created"

book

Article ID: 435737

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

After planned failover, all the vm has WARNING "The object 'vim.Task:########-####-####-####-############:dr.recovery.RecoveryManager.powerOffVm###' has already been deleted or has not been completely created".

Planned failover itself successfully completed.

You might see log like this.

YYYY-MM-DDThh:mm:ss.###+TZ verbose vmware-dr[1331819] [SRM@6876 sub=DrTask ctxID=d9c70ff3 opID=b0013316-0c04-48c9-a173-812096012092-retrieveHistoryWindow] [528bc] Task 'dr.recovery.RecoveryHistoryManager.retrieveHistoryWindow3741' completed with result: (dr.recovery.RecoveryResult) [
:::
-->          (vmodl.fault.ManagedObjectNotFound) {
-->             faultCause = (vmodl.MethodFault) null, 
-->             faultMessage = <unset>, 
-->             obj = 'vim.Task:########-####-####-####-############:dr.recovery.RecoveryManager.powerOffVm###'
-->             msg = "The object 'vim.Task:########-####-####-####-############:dr.recovery.RecoveryManager.powerOffVm###' has already been deleted or has not been completely created"

Environment

VMware Live Site Recovery.

Cause

This could happen when SRM service crashed/restarted during planned failover.

SRM tries to track shutdown of each VM; however, it wouldn't work once SRM service crashed/restarted.

Issue described in SRM Server service crashed during planned failover when at least one of VMs has set recovery.powerOffTimeout=0 can also trigger this situation.

Resolution

Investigate the cause of crash/restart of SRM service during planned failover. If it's an unintended one, raise a support ticket.