All Disks on a single vSAN node are displayed as Absent
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All Disks on a single vSAN node are displayed as Absent

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Article ID: 435720

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Updated On:

Products

VMware vSAN

Issue/Introduction

In the vSphere Client Disk Management screen, all disks on a single node are displayed as Absent.

  • In the output of the esxcli storage core path list and esxcli storage core device list commands, the Status of these disks is normal (active or on).

  • In the output of the esxcli storage core device stats get command, Failed Blocks Read and Failed Blocks Written do not necessarily show high values for all the disks marked as Absent.

  • Clear errors related to disk I/O may not be recorded in the ESXi vmkernel logs.

Environment

VMware vSAN

Cause

A malfunction of the HBA (RAID controller) to which the target disks are connected may be preventing normal I/O to the disks.

Resolution

Consult your hardware vendor to investigate any abnormalities in the operation of the RAID controller. Some RAID controllers maintain their own logs; however, these logs are not included in the ESXi host log bundle and require the use of dedicated tools to retrieve. Please consult your hardware vendor regarding the availability and procedures for obtaining these logs.

The issue may be resolved by shutting down or powering off the target node (ESXi host) and then powering it back on. Depending on the failure state, the shutdown operation may hang; in this case, power off the host using the BMC or the physical power button. If this resolves the issue, it may have been caused by a problem with the RAID controller driver or firmware. If you are using an older version, please update to the latest supported version.

Additional Information

In configurations equipped with multiple RAID controllers for vSAN, a similar failure may only affect the disks connected to a specific RAID controller, rather than all disks on the node.

 

1台の vSAN ノードですべてのディスクが Absent と表示されている