SMTP notifications are not received on SMTP relay host mailjet
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SMTP notifications are not received on SMTP relay host mailjet

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Article ID: 435692

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Configured email notifications to send to SMTP relay server as per KB Setting Up Email Notifications for Alarms generated in vCenter Server.
  • Notification is not received to the SMTP relay host.
  • /var/log/vmware/messages shows errors similar to 
    2026-02-25T07:10:46.048006+01:00 ###-### sendmail[#######]: STARTTLS=read, info: fds=7/6, err=2
    2026-02-25T07:10:46.082763+01:00 ##-#### sendmail[#######]: STARTTLS=read, info: fds=7/6, err=2
    2026-02-25T07:10:46.105129+01:00 ###-#### sendmail[#######]: STARTTLS=client, SSL_shutdown failed: -1
    2026-02-25T07:10:46.047908+01:00 ###-### sendmail[#######]: ##########: to=<user@#############>, delay=00:00:01, xdelay=00:00:01, mailer=relay, pri=32080, relay=in.mailjet.com. [###.###.###.###], dsn=5.7.1, reply=554 5.7.1 <user@########>: Relay access denied, stat=Service unavailable
  • Issue persists after applying workaround Unable to send emails via relay SMTP after replacing vCenter certificates

Environment

vCenter 8.x

Cause

In vCenter the Mail server added under ConfigureSettings General Mail → Mail server is configured to go through in-v3.mailjet.com. Sendmail resolves in-v3.mailjet.com as in.mailjet.com , so when it tries to find the authentication details it tries to find it on in.mailjet.com but the authentication User Name: API Key, Password: Secret Key was created on in-v3.mailjet.com.

Resolution

Update the Mail server to go to in.mailjet.com in vCenter under ConfigureSettings General Mail → Mail server. Alternatively add the authentication details to the SMTP relay server in.mailjet.com or  Please review Mailjet documentation and if required contact Mailjet support for assistance with this.