Troubleshooting ISO Upload Failures in vSphere Client with Certificate Errors for a specific user group
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Troubleshooting ISO Upload Failures in vSphere Client with Certificate Errors for a specific user group

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Article ID: 435687

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • While uploading ISO files to a datastore via the vSphere Client encounter the following error:
    The operation failed for an undetermined reason. Typically, this problem occurs due to certificates that the browser does not trust. If you are using self-signed or custom certificates, open the URL below in a new browser tab and accept the certificate, then retry the operation.

  • Verify whether the issue is related to permissions by attempting the datastore ISO upload using the default vCenter Server Administrator account (e.g., [email protected])
    • If the upload fails with the Administrator account: The issue is likely system-wide. Please refer to following kb https://knowledge.broadcom.com/external/article/343447 for further troubleshooting.
    • If the upload succeeds, but fails for a specific user or group: The issue is permission-based, proceed to the follow this kb.

  • vCenter logs /var/log/vmware/vpxd/vpxd.log

    YYYY-MM-DDTHH:MM:SS.056Z info vpxd[11941] [Originator@6876 sub=HTTP server /folder req=00007f58d8755f30 user=<Domain>\<User>] Got HTTP PUT request for /folder/Unconfirmed 847741.crdownload?dcPath=cloud&dsName=<Datastore Name>&enc=std
    .....
    YYYY-MM-DDTHH:MM:SS.058Z verbose vpxd[11954] [Originator@6876 sub=HTTP server /folder req=00007f58d8755f30] Sent Unauthorized response for PUT /folder/Unconfirmed%20847741.crdownload?dcPath=cloud&dsName=<Datastore Name>&enc=std
    YYYY-MM-DDTHH:MM:SS.058Z verbose vpxd[11954] [Originator@6876 sub=HTTP server /folder req=00007f58d8755f30] Missing required privilege - sent Unauthorized error for PUT /folder/Unconfirmed%20847741.crdownload?dcPath=cloud&dsName=<Datastore Name>&enc=std

Environment

VMware vCenter Server 7.0.x
VMware vCenter Server 8.0.x

Cause

The user account lacks the specific privilege required for the vSphere Client to facilitate the transfer.

Resolution

  • Navigate to the datastore,
  • Select the required datastore, add permissions for the specific user, and ensure that “Propagate to children” is enabled.
  • Update the affected user's role to include the following privileges:
    •  Datastore:
      • Browse datastore
      • Low-level file operations
  • For instructions on how to modify a role, refer to Create a vCenter Server Custom Role
  • After updating the permissions, attempt to upload the ISO file to the datastore again.