VAMI Health Alert: "Appliance has increased swap activity. Add more memory to the machine."
search cancel

VAMI Health Alert: "Appliance has increased swap activity. Add more memory to the machine."

book

Article ID: 435662

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

The vCenter Server Appliance (VCSA) reports a "Warning" overall health status in the vSphere Appliance Management Interface (VAMI). The specific alert indicates: "Appliance has increased swap activity. Add more memory to the machine."

Symptoms:

  • VAMI Summary page shows high swap usage.
  • The vSphere UI Task shows a continuous loop of "Apply solution" and "Check compliance of cluster with image" tasks.
  • Tasks are initiated by the com.vmware.vr (vSphere Replication) service account.
  • The "Apply solution" task fails with the error: A general system error occurred: Health Check for <ESXI_FQDN_OR_IP> failed.
  • /var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server.log reports below for cluster health checks:

    YYYY-MM-DDTHH:MM:SS.680Z info vmware-vum-server[11429] [Originator@6876 sub=EHP opID=80eda5c5-1edd-47a6-81b5-884858301fe4] [host-XXXX] [NSX Manager] [com.vmware.vcIntegrity.lifecycle.health.internal.external_provider] returned status: NOT_OK
    YYYY-MM-DDTHH:MM:SS.625Z error vmware-vum-server[3006461] [Originator@6876 sub=EHP opID=80eda5c5-1edd-47a6-81b5-884858301fe4] Response from localhost/external-tp/http1/<IP>/443/406CF7AD7FD95F933156D7A6F50580E80F047D9C/api/v1/vlcm/esx/health/host/perspectives/initialization/status?action=check: HTTP Status:403 'Forbidden'

    YYYY-MM-DDTHH:MM:SS.712Z info vmware-vum-server[3006463] [Originator@6876 sub=PM.AsyncTask.ClusterApplySolutionTask{55286}] [vciTaskBase 1496] SerializeToVimFault fault:
    --> (vmodl.fault.SystemError) {
    -->    faultCause = (vmodl.MethodFault) null,
    -->    faultMessage = (vmodl.LocalizableMessage) [
    -->       (vmodl.LocalizableMessage) {
    -->          key = "com.vmware.vcIntegrity.lifecycle.TaskError.HealthCheckFailed",
    -->          arg = (vmodl.KeyAnyValue) [
    -->             (vmodl.KeyAnyValue) {
    -->                key = "1",
    -->                value = "<esxi_FQDN\IP>"
    -->             }
    -->          ],
    -->          message = <unset>
    -->       }
    -->    ],
    -->    reason = "vLCM Task failed, see Error Stack for details."
    -->    msg = "{
    -->     "data": null,
    -->     "error_type": "ERROR",
    -->     "messages": [
    -->         {
    -->             "args": [
    -->                 "<esxi_FQDN\IP>"
    -->             ],
    -->             "default_message": "Health Check for '<esxi_FQDN\IP>' failed",
    -->             "id": "com.vmware.vcIntegrity.lifecycle.TaskError.HealthCheckFailed"
    -->         }
    -->     ]
    --> }"
    --> }

Environment

vCenter Server 8.0

Cause

The high swap activity is caused by memory exhaustion resulting from a task-injection loop. When vSphere Replication attempts to install or sync the Host-Based Replication (HBR) agent on ESXi hosts in a vLCM-managed cluster, it triggers an "Apply Solution" task via vLCM.

vLCM performs a mandatory health check of all integrated solutions before proceeding. If NSX is registered as a Compute Manager but lacks the necessary permissions (often due to a missing or misconfigured Service Account), the NSX health check returns an HTTP 403 Forbidden. Because the health check fails, the replication agent installation fails. vSphere Replication immediately retries the task, creating an infinite loop that consumes VCSA memory (specifically in vmware-vum-server and vpxd), eventually forcing the appliance into a heavy swap state.

Resolution

When using vCenter as compute manager in NSX , Please ensure the account being used to connect to vCenter has sufficient privileges.

NSX must be configured to ‘Create Service Account' when registering with vCenter as a Compute Manager

To enable Create Service Account 

  1. In the NSX GUI, navigate to System → Fabric → Compute Managers
  2. Click the checkbox beside the appropriate vCenter Server
  3. Click Edit
  4. Ensure all connection information is correct
  5. Click the slider beside Create Service Account and ensure it reads Yes .
  6. Click Save
  7. Reboot vCenter server to clear the swap activity.

Refer similar steps in kb resolution section: Remediation of Hosts in vLCM cluster fails at the cluster health check

After reboot of vCenter server, Swap activity will reduce and overall health will be green.