Unable to access share point application after deploying the agent.

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Article ID: 4356

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Updated On:

Products

APP PERF MANAGEMENT CA Application Performance Management Agent (APM / Wily / Introscope) CUSTOMER EXPERIENCE MANAGER INTROSCOPE

Issue/Introduction

Installed APM .net agent  including share point option(CA APM for SOA ,CA APM for Microsoft share point and CA APM for SOA share point monitor) for monitoring the share point application > Up the share point monitor agent and IIS > Access the share point  application URL/Webpage > It is taking time to load .

Cause

Socket tracing was enabled from APM .net agent side and  it was creating addition load to share point.

Environment

APM .net agent installed on Microsoft share point application server.

Resolution

  1. Make sure all installation prerequisite are exactly same according to APM guide (found at https://docops.ca.com/ca-apm/10-1/en/extending/microsoft-sharepoint).
  2. Stop all share point related services.
  3. Stop IIS.
  4. Uninstall and Reinstall .net agent enabling CA APM for SOA ,CA APM for Microsoft share point and CA APM for SOA share point monitor.
  5. Start all the share point services.
  6. From the share point agent folder agent profile file enable the perf mon monitoring and from the wily agent folder change the intro-scope agent profile file
      the default -full pbd to default-typical .pdb .
  7. Start  IIS.
  8. Start APM share point monitor agent and APM  Performance Agent.
  9.  In agent machine etc/hosts file add the agent machine IP and hostname .