Microsoft Office 365 fails to update with Patch Management
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Microsoft Office 365 fails to update with Patch Management

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Article ID: 435542

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Updated On:

Products

Client Management Suite

Issue/Introduction

It is noticed that Office 365 is not being updated on most systems where the updates are showing applicable. The number of successfully patched systems is low causing compliance issues.

Assessment Scans are successful and the update policy has the correct target systems

If Office 365 updates are manually installed, the following is seen:

You're up to date!
The latest version of Microsoft 365 and Office approved by your system admin is installed on your computer

Environment

ITMS 8.x

Patch Management Solution 8.x

Cause

In this case, the message that appeared when manually installing the Office 365 update was the key in resolving the issue.

Although Office 365 was not updated on the target machine, the installation success message indicated the latest Microsoft 365 and Office updates "approved by your system admin is installed"

It was discovered that a Registry key set by GPO prevented installation of updates past a specific version:

Regkey path: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\cloud\office\16.0\Common\officeupdate

String 'updatetargetversion' specified a target version lower than the version attempted to be installed with Patch

Resolution

Updating this string 'updatetargetversion' to the latest version or deleting the key successfully resolved the issue in at least one case.

Before making any changes to the registry, it is important to first make a backup in the event of unforeseen issues. Never delete Registry keys without a clear understanding of the impact. For further information about this Registry key and limitation, refer to Microsoft documentation.

Additional Information

Deploying Microsoft Office 365 updates with Patch Management Solution