PWP port not released
search cancel

PWP port not released

book

Article ID: 435530

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

When, due to long running transaction or network issue the PWP switches to a different server, the initial PWP does not always release its port (default 2270).

When a subsequent PWP switch occurs, back to the initial server, the system gets stuck because the PWP port is not available.

 

Symptoms that may be observed include:

  • The Administration perspective in the Automic Web Interface (AWI) shows multiple (PWP) processes as having the PWP port
  • Java processes (JWP/JCP) may appear offline in the AWI while appearing online in the Service Manager
  • Interruption of the SNMP messages

Cause

DE179631 and DE182697

Resolution

Solution:

Update to a fix version listed below or a newer version if available.


Fix version:

Component(s): Automation Engine

Automation.Engine 24.4.5 - Planned release June 2026
Automation.Engine 26.1.0 - Planned release July 2026

 

Workaround:

Stop and start the processes occupying the PWP port

Additional Information

Public Description: A problem has been fixed that prevents the system to use the correct port when switching the PWP role