ESXi hosts report Internal Error when updating Syslog.global.logHost
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ESXi hosts report Internal Error when updating Syslog.global.logHost

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Article ID: 435380

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

When attempting to update the `Syslog.global.logHost` advanced setting on an ESXi host via vCenter Server or the Host Client, the operation fails with the following error:
A general system error occurred: Internal error

Environment

ESXi 8.X

Cause

The ESXi host is unable to resolve the Fully Qualified Domain Name (FQDN) of the configured syslog server.

Resolution

Ensure the ESXi host can resolve the syslog server's FQDN.

  1. Login to the ESXi shell via SSH
  2. nslookup <fqdn of host>
  3. If it comes back unable to resolve the host then it will need to be added to the DNS server that is providing the name resolution or use the below workaround.

If DNS is unavailable, manually add the entry to the host's `/etc/hosts` file:

  1. Log in to the ESXi shell via SSH.
  2. Edit the `/etc/hosts` file and add the IP and FQDN of the syslog server.
  3. Verify resolution using `nslookup` or `ping`