A vmkernel port (vmk#) is not displaying when viewed in the vCenter Server UI for the ESXi Host
search cancel

A vmkernel port (vmk#) is not displaying when viewed in the vCenter Server UI for the ESXi Host

book

Article ID: 435361

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

When viewing the vDS for a specific Host in the vCenter UI, the port group for the vmkernel exists, but the vmkernel does not show as associated/visible.

Network configuration output confirms that vmk0 is assigned to a conflict port (c-490) on the distributed switch.

For example, when running esxcfg-vswitch -l on the Host CMD line, output shows similarly for vmk0 with the "c-" preceding the port ID.

 DVPort ID            In Use      Client
 76                            1           vmnic0
 119                          1           vmk1
 c-490                       1           vmk0     <<<<<<======

Cause

Any port with the prefix "c-" is a conflict port and is invalid. vCenter Server creates a conflict port if multiple objects point to the same port.  This is causing the visibility issues within the vCenter Server UI.

Resolution

To resolve the issue:

  • Create a new temporary distributed port group for the vmkernel traffic. Ensure the port group is configured with the correct VLAN and the appropriate uplink as active.
  • Migrate the vmkernel interface from the original port group to the newly created temporary port group.
  • Migrate the vmkernel from the temporary port group back to the original management port group.
  • This will change the port ID, resolving the issue.

Additional Information

Issue is similar to c-port issue with virtual machines:  vSphere Distributed Switch (VDS) contains dvPort IDs with prefix 'c-'