SaaS AWI Login Error "No connection to ... CPs ... jcp-ws-1:8443"
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SaaS AWI Login Error "No connection to ... CPs ... jcp-ws-1:8443"

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Article ID: 435344

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Updated On:

Products

Automic SaaS

Issue/Introduction

Users are unable to log in to the Automic Web Interface (AWI). The following error is displayed: No connection to the following CPs could be established: jcp-ws-1:8443 Please make sure that the system meets the minimum requirement for processes and that it uses WS.PORT to establish the connection.

No other symptoms are seen except an inability to log in to the AWI with the error above.  Since multiple AWI nodes are in place in a SaaS system some percentage (50% or 66%) of logins are successful and the rest are not.

Environment

Automic SaaS v24

Cause

Defect (DE182534) in the JavaAPI WebSocket implementation causes the JCP to incorrectly maintain an old connection ID. When the AWI attempts to reconnect, the JCP flags it as a duplicate (U00045419), suspending the new connection 

Resolution

Resolution

This will be fixed with the SaaS upgrade to 24.6.0 HF4

Workaround

The affected AWI pod must be restarted to clear the stale connection session.  Monitoring is in place for SaaS environments and AWI pods hitting this condition will be restarted automatically.