Group Size exceeded Alarm and the UUID of the Group cannot be found
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Group Size exceeded Alarm and the UUID of the Group cannot be found

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Article ID: 435334

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Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX version is 4.2.1 and older
  • The error message:
    Group (UUID:########-####-####-####-############,Path:/infra/segments/########-####-####-####-############) 
    as at least 10011 translated elements which is at or greater than the maximum numbers limit of 10000. 
    This can result in long processing times and can lead to timeouts and outages. 
    The current count for each element type is as follows. 
    IP Addresses:504, MAC Addresses:582, VIFS:4462, Logical switch ports:4463, Logical router ports:0, AdGroups:0.
  • The search for the UUID will not have any results. It cannot be found.

Environment

NSX 4.2.1 and older

Cause

  • CCP internally creates ContainerCacheEntry object for these types - LogicalSwitch, LogicalSwitchPort, Group, ExcludeList.
  • The alarm was being raised based on the ContainerCacheEntry itself without checking if the entry is for a Group type or not.

Resolution