Unable to activate VMware Live recovery site pair.One of the appliance is not visible on the Cloud management console.
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Unable to activate VMware Live recovery site pair.One of the appliance is not visible on the Cloud management console.

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Article ID: 435323

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

While accessing cloud console to activate the recovery Site Pair one of the domains in not visible.

Environment

VMware Live Site recovery 9.0.2.2.

VMware vSphere ESX 8.0 U3

Cause

The cause is identified as HMS privilege id-s missing for the appliance in the vCenter to which it is registered.

The issue can be verified from the dpx.log on the broker that is reporting missing in the Site pair

dpx.log 

[xxxx-xx-xx xx:xx:xxx.472 UTC] [dpx-agent] WARN  [vcId='NA' host='tc1vavmsrm03.tech-01.net'] [thread='dpx-common-thread0'] HmsConn@vSphere Replication Appliance. - Failed to init vmomi client for HMS@414058064
java.util.concurrent.CompletionException: (vim.fault.NoPermission) {
   faultCause = null,
   faultMessage = null,
   object = ManagedObjectReference: type = HmsRemoteSiteManager, value = site-manager, serverGuid = xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx,
   privilegeId = HmsRemote.com.vmware.vcHms.Hms.View,
   missingPrivileges = (vim.fault.EntityPrivileges) [
      (vim.fault.EntityPrivileges) {
         dynamicType = null,
         dynamicProperty = null,
         entity = ManagedObjectReference: type = HmsRemoteSiteManager, value = site-manager, serverGuid = xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxx,
         privilegeIds = (STRING) [
            HmsRemote.com.vmware.vcHms.Hms.View
         ]
      }
   ]
}

 It can also be verified using the below link

 https://vCenter/mob/?moid=AuthorizationManager&method=fetchUserPrivilegeOnEntities

Use fetchUserPrivilegeOnEntities() VC api (through MOB) to check whether dpx agent service account (dpxa-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx) has required privileges on VC root folder. HMS privilege id-s were missing.

This leads to dpx agent unable to login into HMS -> unable to set orgId -> unable to report correct status to cloud service and activate cloud sub.

Resolution

Reconfigure the broker appliance(hms/VR Appliance ) that is reporting the issue using the below link.

https://techdocs.broadcom.com/us/en/vmware-cis/live-recovery/live-site-recovery/9-0/overview/reconfiguring-the-site-recovery-manager-virtual-appliance/reconfigure-the-site-recovery-manager-appliance.html 

Additional Information

Note:From version 9.0.3 and later hms-va and srm-va are combined into single appliance (dpca) and some of the above considerations are not relevant (i.e they are specific to 9.0.2 ).