Error “Service is not available at this time” when accessing SDDC Manager instance in VCF Operations UI
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Error “Service is not available at this time” when accessing SDDC Manager instance in VCF Operations UI

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Article ID: 435258

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Updated On:

Products

VMware SDDC Manager VCF Operations

Issue/Introduction

  • While navigating to VCF Operations → Fleet Management → Lifecycle → VCF Instances → VCF instance, UI consistently displays the error:
    “Service or view is not available at this time.”

  • Logs on VCF Operations located at /storage/log/vcops/log/web-vcf.log shows entries similar to:

YYYY-MM-DDThh:mm:ss ERROR web-vcf 29394 [ops@4413 threadId="75006" threadName="ajp-nio-127.0.0.1-8009-exec-2402"] [com.vmware.vcf.operations.ui.proxy.ProxyUtil.error] - Error occurred while serving the path: vcf-operations/plug/sddc-<plugin-id>/plugin/ops-plugin/index.html.
YYYY-MM-DDThh:mm:ss ERROR web-vcf 29394 [ops@4413 threadId="75006" threadName="ajp-nio-127.0.0.1-8009-exec-2402"] [com.vmware.vcf.operations.ui.proxy.ProxyUtil.error] - Connect timed out

Environment

VCF 9.0
VCF Operations

Cause

This issue is caused by a network communication failure between the SDDC Manager and the VCF Operations Analytics Nodes.
VCF Operations requires direct HTTPS connectivity over port 443 from SDDC Manager to all Analytics Nodes to retrieve and display instance details.

Resolution

1. Ensure that port 443 is open and reachable between:

  • SDDC Manager
  • VCF Operations Analytics Nodes

2. To determine connectivity, run the following commands from SDDC Manager to all Ops analytics nodes.

curl -v telnet://<Ops Node>:443
openssl s_client -connect <Ops Nodes>:443
A successful connection returns connected or established connection.

Refer VMware Ports and Protocols for What Ports are Needed by VMware Products and Solutions.