Network connectivity issues on Management Network despite correct IP Hash configuration on the standard virtual switch
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Network connectivity issues on Management Network despite correct IP Hash configuration on the standard virtual switch

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Article ID: 435247

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Network connectivity to the ESXi host's Management Network is unstable, intermittently drops, or is completely lost.
The upstream physical switch is configured with Link Aggregation (e.g., Static Port-Channel).
Communication normalizes when only a single physical uplink is connected. However, traffic is dropped when multiple uplinks are connected.
The Teaming and failover policy at the standard virtual switch level is correctly configured to "Route based on IP hash".

Environment

VMware vSphere 8.0

Cause

This issue occurs because the Management Network port group's load balancing policy overrides the standard virtual switch level which is configured as "Route based on IP hash".

Resolution

To resolve this issue, correct the load balancing policy of the Management Network port group via the vSphere Client.

  1. Log in to the vSphere Client and navigate to the affected ESXi host.
  2. Go to Configure > Networking > Virtual switches.
  3. ocate the virtual switch (e.g., vSwitch0) and expand it to view the port groups.
  4. Click the vertical ellipsis (three-dot) icon next to the Management Network port group and select Edit Settings.
  5. Select Teaming and failover from the left pane.
  6. Under the Load balancing section, deselect the Override checkbox to allow the port group to inherit the virtual switch's policy ("Route based on IP hash"). Alternatively, explicitly select "Route based on IP hash" from the drop-down menu if you keep the override enabled.
  7. Click OK to apply the configuration.

Additional Information

Host requirements for link aggregation (etherchannel, port channel, or LACP) in ESXi