vSAN objects showing inaccessible following network outage
search cancel

vSAN objects showing inaccessible following network outage

book

Article ID: 435212

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

Following a network outage, various VMs will show as "Inaccessible" in vCenter.

  • One or more Virtual Machines (VMs) are inaccessible or powered off.
  • vSAN health will display Unknown vSAN objects with a status of "inaccessible" 
  • vSAN hosts report as healthy, fully connected, and are not in maintenance mode
  • Running esxcli vsan debug object list --health=inaccessible command shows objects listed as "inaccessible - Object is initializing or creating."

Environment

vSAN OSA 7.x, 8.x

Cause

This issue occurs because the Distributed Object Manager (DOM) owner for the affected vSAN objects retains a stale state post-outage. The DOM owner fails to properly update and recognize available components after the network recovers, resulting in a false "inaccessible" state even though the underlying data components are healthy and available.

Resolution

Verify the ESXI hosts are connect and validate settings in Additional Information section. 

Contact Broadcom Support for further assitance

Additional Information

Verify that vSAN component operations are not paused on all ESXI hosts in cluster:

  1. SSH into all ESXI hosts
  2. Check the current value of the "DOMPauseAllCCPs" setting:
    esxcfg-advcfg -g /VSAN/DOMPauseAllCCPs
  3. If the value is "1", reset it to the default "0" to allow object ownership tasks to proceed:
    esxcfg-advcfg -s 0 /VSAN/DOMPauseAllCCPs

Verify that all ESXI hosts in cluster are not in a network partitioned state

vSAN component failure states

vSAN inaccessible objects after cluster shutdown and restart