VLSR Protection Group "Device not found error" after adding new disk
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VLSR Protection Group "Device not found error" after adding new disk

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Article ID: 435198

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

In VMware Live Site Recovery (VLSR), adding a new virtual disk to an already protected Virtual Machine that utilizes Enhanced Replication with the "Auto-include new disks in replication" option enabled results in a Protection Group error.

The Protection Status for the virtual machine under Protection Groups changes to: Device not found: Hard disk #

The /var/log/vmware/srm/vmware-dr.log on the VLSR server displays errors similar to:

Failed to auto-configure device with unknown backing type: vim.vm.device.VirtualDisk.FlatVer2BackingInfo 
Unable to auto-configure device with key ####. No relevant mapping has been found.


Environment

VMware Live Site Recovery (VLSR) 9.0.5
VMware Live Site Recovery (VLSR) 9.0.3

Cause

This is a known issue in VLSR 9.0.3 and 9.0.5 where the auto-configuration logic fails to automatically map standard virtual disk backing types (FlatVer2BackingInfo) to the recovery site placeholder VM after a post-protection hardware addition. Engineering is aware of the issue and a fix will be released in a future version.

Resolution

A permanent fix will be released in a future version of VLSR.

To work around the issue and restore the Protection Group to a healthy state, reconfigure the replication for the virtual machine:

  1. In the vSphere Client, navigate to Site Recovery > Replications.

  2. Right-click the affected Virtual Machine and select Reconfigure.

  3. Advance to the Disks/Target datastore section to confirm the newly added disk is checked.

  4. Complete the wizard to force a synchronization of the hardware metadata.