VM backup fails with "Fail to get vm parent" using Veritas due to placement in vCLS folder or namespace
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VM backup fails with "Fail to get vm parent" using Veritas due to placement in vCLS folder or namespace

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Article ID: 435159

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Virtual machine (VM) backups using Veritas fail when attempting to open the virtual disk.

  • The backup logs under Detailed jobs in Activity Monitor in the Veritas Administrative console report a failure to obtain an Network File Copy (NFC) ticket and an inability to resolve the virtual machine's parent object, the following snippet may be observed 

YYYY/MM/DD HH:MMM:SS : g_vixInterfaceLogger:libvix.cpp:1803 <DEBUG> : [VFM_ESINFO] VixDiskLib: Error occurred when obtaining NFC ticket for <VM_Path> Error 1 (Unknown error) (Fail to get vm parent) at 3656.
YYYY/MM/DD HH:MMM:SS : g_vixInterfaceLogger:libvix.cpp:1803 <DEBUG> : [VFM_ESINFO] VixDiskLib: VixDiskLib_OpenEx: Cannot open disk <VM_Path>. Error 1 (Unknown error) at 7426.
YYYY/MM/DD HH:MMM:SS : g_vixInterfaceLogger:libvix.cpp:1803 <DEBUG> : [VFM_ESINFO] VixDiskLib: VixDiskLib_Open: Cannot open disk <VM_Path>. Error 1 (Unknown error) at 7504. 

Cause

  • Placing a VM in a specialized container (such as a vCLS or Tanzu Namespace) prevents the Veritas service account from identifying the standard parent folder structure required to obtain an NFC ticket for disk access. 

  • Validate the Parent and ParentVApp attribute by navigating to the Managed object browser(MOB) page with local SSO administrator on the VM using the URI https://<vcenter_ip>/mob/?moid=vm-<id> (VMID can be found by looking at the URI while navigating to the VM on vCenter Server)  :
    • VCLS folder or Namespace, in parent attribute 
    • parentVApp attribute has the value Unset.


Resolution

To resolve this issue, relocate the virtual machine to a standard folder in inventory, using one of the following methods:

Workaround 1 : Relocate the VM into a standard inventory folder. 

  1. Log in to the vCenter Server with local SSO Admininstrator account.
  2. Navigate to the VM in the inventory.
  3. Right-click the VM and select Move to folder
  4. Select an inventory folder (Eg: Discovered Virtual machines.)
  5. Retry the backup.

Workaround 2 : Unregister and Re-register VM

  1. Power off the VM.
  2. Right-click the VM and select Remove from inventory
    • Note: Do not select Delete from disk
  3. Browse the datastore in which the VM was located, locate the .vmx file, and select Register VM
  4. Power on the VM and retry the backup.

Additional Information

Refer to the following Veritas document for information related to the Veritas error : VMware Backups using NBD transport are failing with error "unexpected termination of client"