Unable to view Protection Groups under the vSAN Data Protection UI
search cancel

Unable to view Protection Groups under the vSAN Data Protection UI

book

Article ID: 435114

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms

  • Unable to create new protection group because of the error "Failed to fetch VM UUIDs for protection group PROTECTION_GROUP_NAME"
  • Navigating to Cluster> configure> vSAN > Data protection we observe below UI error
  • The affected protection group is not populating in the vCenter UI under Cluster > vSAN > vSAN Data Protection > Protection Groups.
  • Issue observed after performing a VLR appliance redeployment and recovering the Snapservice database.

Environment

VMware Live Recovery 9.X

VMware vSAN 9.0

Cause

  • This issue was triggered when virtual machines within a designated Protection Group were permanently deleted from the disk.
  • The API response for listing protection groups failed and returned an exception due to the missing virtual machines.
  • Due to the API failure, the vSphere Client was unable to retrieve inventory data, preventing the display of the affected group.

Resolution

Issue resolved in VMware Cloud Foundation (VCF) 9.1

For environments running earlier versions, contact Broadcom Support.