Logging in via LDAP is not possible; the AWI displays an 'Access denied' message.
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Logging in via LDAP is not possible; the AWI displays an 'Access denied' message.

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Article ID: 435113

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Updated On:

Products

CA Automic Workload Automation - Automation Engine Automic SaaS

Issue/Introduction

Login attempts through the AWI are failing.

The following message is shown:

 Logon error: Access denied 

The JWP log shows the following messages:

U00045033 Log on to LDAP server '[LDAP_SERVER]:389' with user '[DOMAIN]\[USERNAME]'.
U00045014 Exception 'javax.naming.CommunicationException: "[LDAP_SERVER]:389"' at 'com.sun.jndi.ldap.Connection.<init>():251'.
U00045015 The previous error was caused by 'java.net.SocketException: "Connection reset"' at 'sun.nio.ch.NioSocketImpl.implRead():328'.

The UC_LDAP_DOMAIN variable in client 0 is configured with all the correct values.

Environment

Automic Automation Engine 24.X

Cause

There were two UC_LDAP_DOMAIN variables in non-zero clients that contained incorrect values.

Resolution

Remove these variables from all non-zero clients. Afterward, LDAP user logins will work as expected.