Unable to connect to Web Console or Remote Console from VCF Automation 9.0.x Soft Tenant
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Unable to connect to Web Console or Remote Console from VCF Automation 9.0.x Soft Tenant

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Article ID: 435109

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Updated On:

Products

VCF Automation

Issue/Introduction

  • An issue occurs in the VCF Automation 9.0.x Soft Tenant when accessing Web Consoles or Remote Consoles for VMs from Organizations through:

    Organization Portal > Build & Deploy > Instances > Virtual Machines > Selected Virtual Machine > Open Web Console

  • Any input from a mouse or keyboard results in the message Error appearing above the Remote Console, as seen below:

  • Additionally, if you review the browser's developer tools console, you will observe the following errors:
    errorType: "protocolerror"
    [Info ] Disconnected: illegal server message type 130

Environment

VCF Automation 9.0.x

Cause

The issue is related to the connection to vCenter closing from the Console before being sent, causing the error when sending input to the Console.

As seen in the provisioning-service-app logs (/var/log/services-log/prelude/provisioning-service-app/file-logs/provisioning-service-app.log):

#-#-#T#:#:#.#Z ERROR provisioning [host='provisioning-service--####' thread='reactor-http-epoll-#' user='' org='' trace='' parent='' span=''] c.v.w.p.s.c.WebSocketClientToVCenterHost.lambda$handle$#:# - [vRA host: server.example.com communicating with vCenter Host: wss://server.example.com:#/ticket/#####]: Exception [Connection has been closed BEFORE send operation] received while sending message from client. This may be due to browser window closed by the end user. Closing open websocket sessions.

 

Resolution

Currently, there is no resolution. This issue is scheduled to be resolved in the upcoming VCF Automation 9.1 release.

Please subscribe to this article to be notified when the release becomes available and the article is updated with download instructions.