Test Profile fails though device is reachable by SNMP
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Test Profile fails though device is reachable by SNMP

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Article ID: 435108

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Updated On:

Products

Network Flow Analysis

Issue/Introduction

When attempting to test an SNMP profile in Network Flow Analysis (NFA), the Test Profile operation fails. However, using the SAPWalk or other equivalent SNMPwalk utility with the same credentials from the same server succeeds.

Device name is not getting updated in NFA

Error observed in Harvester's Poller log:

Snmp response error: USM passphrases must be at least 8 bytes long (RFC3414 11.2)

Environment

NFA - 25.x

Cause

SNMP credential configured for the device do not meet SNMP RFC guidance. Error indicates that credential must be minimum 8 bytes length.  

According to RFC3414, user names, password, priv password, and auth password, all should be more than 8 characters.

Resolution

Modify the SNMP credentials on the target device on which issue is observed.

  1. Log in to the target network device and update the SNMP password or community string to a value with more than 8 characters.
  2. In the NetOps Portal/CAPC, navigate to SNMP Profiles.
  3. Edit the failing profile and update the password/community string to match the new, longer credential.
  4. Click Save.
  5. Select the profile and click Test Profile to verify success.