The virtual machine is not configured for replication error during initial sync in vSphere Replication
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The virtual machine is not configured for replication error during initial sync in vSphere Replication

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Article ID: 434892

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

When you configure a virtual machine for vSphere Replication, the initial synchronization starts but fails after reaching between 1% and 18% completion. In the Disaster Recovery (DR) UI, you receive the following error:

"The virtual machine is not configured for replication."

If you review the hbrsrv logs on the active vSphere Replication appliance, you may observe connection reset errors similar to the following:

error hbrsrv [Originator@6876 sub=Main] request callback failed: Failed to read: End of file
info hbrsrv [Originator@6876 sub=StatsLog] HbrEvent: {"eventID":"lwdConnectionReset"...

Additionally, in the vCenter logs from the source site , you may see API calls where replication is being rapidly enabled and then immediately disabled (vim.HbrManager.disableReplication) by different IP addresses.

envoy-access.log: 2026-0x-0xTxx:xx:xx.xxZ info envoy[2801] [Originator@6876 sub=Default] 2026-0x-0xTxx:xx:xx.xxZ POST /sdk 200 via_upstream - 799 492 gzip 6 6 0 10.180.226.151:47908 HTTP/1.1 TLSv1.2  {#IP address of HMS server}:443 127.0.0.1:34234 HTTP/2 - 127.0.0.1:8085 "684df7f9-cbee-4285-9e19-b4657dae77fe-HMS-552103" "CreateTask"

envoy-access.log:2026-0x-0xTxx:xx:xx.xxZ info envoy[2801] [Originator@6876 sub=Default] 2026-0x-0xTxx:xx:xx.xxZ POST /sdk 200 via_upstream - 571 250 gzip 2 2 0 10.163.244.45:39548 HTTP/1.1 TLSv1.2 {#Different IP address than the above}:443 127.0.0.1:34260 HTTP/2 - 127.0.0.1:8085 "d07c9eda-fcbc-4c94-8e99-78e21800639b-HMSINT-1045507206" "Fetch"

Environment

  • VMware ESXi 8.0
  • vSphere Replication 9.x

Cause

This issue occurs when multiple vSphere Replication Management Server (HMS) instances are registered to the same source vCenter Server. Only one HMS registration is supported per vCenter Server.

If a secondary, stale, or unknown vSphere Replication appliance is registered to the vCenter Lookup Service, it will conflict with your active appliance. The vSphere Replication logic dictates that if an HMS instance detects replications it does not manage, it will automatically clean them up by calling HbrManager.disableReplication. This causes the rogue appliance to actively break the replication connection shortly after the legitimate appliance establishes it.

Resolution

To resolve this issue, you must unregister the stale vSphere Replication instance from the Lookup Service and re-register the correct active instance.

Follow these steps:

  1. Identify the IP address of the stale or rogue vSphere Replication Management Server (VRMS) by reviewing the envoy-access logs from source vCenter tasks to see which IP is issuing the disableReplication API calls.
  2. Break the site pair in the vSphere DR UI.
  3. Unregister the stale VRMS appliance from the vCenter Server Lookup Service.
  4. Re-configure your legitimate, active VRMS appliance to the vCenter Server.
  5. Re-connect the site pair.
  6. Configure the virtual machines for replication again.