ESXi 8.0 PSOD in fnic_unclaim_lunlist with Cisco nfnic Driver
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ESXi 8.0 PSOD in fnic_unclaim_lunlist with Cisco nfnic Driver

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Article ID: 434775

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

An ESXi host becomes unresponsive, is not pingable, and the management network cannot be restarted from the console. Attempting to access the ESXi shell via the console fails. Rebooting the host immediately results in a Purple Screen of Death (PSOD).

The PSOD stack trace indicates a fatal panic during a storage path unclaim operation involving the nfnic module:

VMware ESXi 8.0.3 [Releasebuild-24784735 x86_64]
Module(s) involved in panic: [...] Infni : 5.0.0.45-10EM.800.1.0.20613240 (External)]
PCPU64:2098286/unclaim path
[0x420001da3e69]vmk_ScsiScanDeleteAdapterPath@vmkernel#nover+0x66
[0x4200029cd27c]fnic_unclaim_lunlist@(nfnic)#<None>+0x195
[0x4200029cd4d9]fnic_handle_unclaim@(nfnic)#<None>+0x142

Environment

VMware ESXi 8.0 U3

Cause

The fatal kernel panic is caused by an incompatibility or fault in the third-party Cisco nfnic asynchronous driver (specifically version 5.0.0.45) when handling a SCSI adapter path deletion and VMFS volume eviction process (fnic_unclaim_lunlist).

Resolution

 

  • Engage Cisco UCS Hardware Support to report the PSOD occurring during the fnic_unclaim_lunlist function.

  • Verify the Broadcom Hardware Compatibility List (HCL) and Cisco UCS Hardware Compatibility Matrix to identify a validated nfnic driver version (such as 5.0.0.46-1OEM or later) that aligns with the currently running UCS server firmware.

  • Download the certified asynchronous driver from the Broadcom Support Portal using the instructions for finding ESXi drivers.

  • Install/Update the validated nfnic driver to the affected ESXi host(s) to resolve the unclaim panics.

 

Additional Information

Configuring ESXi coredump to file instead of partition

 Finding ESXi Drivers in the Broadcom Support Portal

Broadcom HCL: Cisco UCS VIC Fnic Controller Compatibility