SEPM のインストールにより SQL Server Browser サービスが無効化される
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SEPM のインストールにより SQL Server Browser サービスが無効化される

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Article ID: 434749

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Endpoint Protection

Issue/Introduction

SQL Server Express を使用するサードパーティ製アプリケーションが導入済みのサーバーに、埋め込みデータベース構成の Symantec Endpoint Protection Manager (SEPM) をインストールすると、SQL Server Browser サービスの [スタートアップの種類] が「自動」から「無効」に変更される。これにより、既存のアプリケーションからデータベースへの接続に失敗する事象が発生する。

Environment

  • 埋め込みデータベース (SQL Server Express) を使用する SEPM 14.3 RU1 以降

Cause

SEPM がインストールする SQL Server Express の構成ファイルにおいて、SQL Server Browser サービスのスタートアップの種類を「無効」と定義しているため。

Resolution

SQL Server Browser サービスの [スタートアップの種類] を、以下の手順で手動にて元の設定に戻してください。

  1. Windows の [サービス] 管理コンソール (services.msc) を起動します。
  2. [SQL Server Browser] サービスをダブルクリックしてプロパティを開きます。
  3. [全般] タブの [スタートアップの種類] を [自動] に変更し、[適用] をクリックします。
  4. 必要に応じて [開始] ボタンをクリックし、サービスを起動してください。