Error seen in emc-smarts-reports and generic-reports blocks on upgrade
search cancel

Error seen in emc-smarts-reports and generic-reports blocks on upgrade

book

Article ID: 434733

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

During an upgrade of Watch4net | M&R from version 7.8 to 7.9, the following errors are encountered while updating blocks such as emc-smarts-reportsemc-watch4net-health-reports, or generic-reports:

MasterAccessorServiceException Error importing report pack : (ReportPack cannot be saved in master database!)

WARNING: For this SolutionPack to work properly, you should fix these errors, and then reconfigure (update) this block in order to replay the actions that failed.

Environment

All supported releases of Watch4net|M&R

Cause

TheMasterAccessorServicerelies on the Web Application (Tomcat) and the underlying MySQL database to be fully operational to process report pack imports. If the database service is unavailable or unresponsive during the block update phase of the upgrade, theMasterAccessorServicecannot save the report pack metadata to the master database 

Resolution

  1. Verify Services: Ensure the MySQL database is running and stable.

  2. Reconfigure via Frontend: Log in to the M&R Admin UI.

  3. Update Blocks: Navigate to the failed blocks and trigger a "Reconfigure" action.

    • This allows the system to replay the failed report pack import actions now that the database is available.