Symantec Directory Manager: After upgrading to 14.1.07, management ui (node.js) and SCIM Server services stay in 'paused' status (Windows)
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Article ID: 434682
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Updated On:
Products
CA Directory
Issue/Introduction
You may experience a problem with management UI (node.js) and SCIM Server services to get stuck in 'paused' status when attempted to start after to 14.1.07 version from a previous Service Pack on Windows.
Cause
The node_modules for management UI component might be corrupted.
Resolution
The node_modules for management UI component might be corrupted. To fix this, follow the manual steps outlined below.
Take a backup of the entire existing %DXHOME%\..\management-ui folder EXCEPT the 'node_modules' and 'logs' folders.
Rename node_modules folder (e.g. node_modeules_old which can be deleted later once all the steps are successfully done)
Rename the logs folder (e.g. logs_old)
Create a new folder and copy the %DXHOME%\..\management-ui\ca_mgmt_ui_static.exe file to that new folder.
Run ca_mgmt_ui_static.exeas an Administrator and give path to the newly created folder.
This will extract four folders: api-server, node_modules, public, scim-server
Copy and replace the above four folders to existing/original %DXHOME%\..\management-ui folder.
Copy api-server\certs folder from backup (taken in step 1 above) to existing %DXHOME%\..\management-ui\api-server folder
Delete the backup (e.g. node_modules_old) folder.
Mamagement-ui (node.js) and SCIM server services should be able to start successfully from Windows Services Panel now.