Veeam での仮想マシンのバックアップがエラー "DiskLib error: [13].The file is locked or in use -- File open failed: File not open" で失敗する
search cancel

Veeam での仮想マシンのバックアップがエラー "DiskLib error: [13].The file is locked or in use -- File open failed: File not open" で失敗する

book

Article ID: 434579

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

免責事項: これは英文の記事「VM Backup Fails in Veeam with Error "DiskLib error: [13].The file is locked or in use -- File open failed: File not open"」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • Veeam から開始された仮想マシンのバックアップが次のエラーで失敗します。
    Error: DiskLib error: [13].The file is locked or in use -- File open failed: File not open

  • この問題は、バックアップが特定の ESXi ホストで開始された場合にのみ発生します。ただし、同じ仮想マシンのバックアップを別のホストから開始すると成功します。
  • バックアップをトリガーすると、Veeam ジョブが次のエラーメッセージで失敗します。
VM owner: ####
Getting VM info from vSphere
Error: DiskLib error: [13].The file is locked or in use -- File open failed: File not open Failed to create N ...
Processing finished with errors at Error: DiskLib error: [13].The file is locked or in use -- File open failed: File not open
Failed to create NFC download stream. NFC path: [nfc://conn:###.##.##.#,nfchost:host-#####,stg:datastore-####@####-01-####/####-01-####.vmx].
Agent failed to process method {Transfer.FileToText).

 

Cause

Veeam プロキシがネットワーク経由で ESXi ホストに到達できません。その結果、バックアップ要求が ESXi ホストに到達せず、対応するログや ESXi 側から開始されるバックアップタスクはありません。

確認事項:

  • パケットキャプチャで、Veeam サーバーから ESXi ホストへのトラフィックがないことが確認できます。

  • ESXi ホストのログにエラーは報告されません。

Resolution

 

  • vCenter で ESXi ホストのステータスを確認し、手動でスナップショットを作成する
    • ホストが vCenter に接続され、健全な状態であることを確認してください。
    • ホストのサマリとイベントで、エラーや警告がないか確認してください。
    • vSphere UI から、影響を受ける仮想マシンのスナップショットを手動で作成可能であることを確認してください。
    • 手動でのスナップショット作成が失敗した場合は、ホストレベルのエラーがないか確認し、vCenter と ESXi ホスト間の接続を確認して、検出された問題を解決してください。
  • ネットワーク接続の確認

    • Veeam バックアッププロキシから、影響を受ける ESXi ホストへ正常にネットワーク接続が可能であることを確認してください。

    • Veeam プロキシと ESXi ホスト間のトラフィックをブロックするファイアウォールルールやネットワーク ACL がないことを確認してください。

  • Veeam プロキシ構成の検証

    • ジョブに正しいプロキシが選択されていることを確認してください。

    • プロキシが、必要なネットワークセグメントと ESXi ホストにアクセスできることを確認してください。

  • Veeam サポートへのお問い合わせ

    • 接続と構成を確認しても問題が解決しない場合は、Veeam サポートに連絡して詳細なトラブルシューティングを行ってください。