SNMPv3 communication problem
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SNMPv3 communication problem

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Article ID: 434495

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Updated On:

Products

Network Observability

Issue/Introduction

Device discovery fails for several network devices when using SNMPv3 profiles in DX NetOps Classic․​​​​‌​‍

ERROR MESSAGE: "Error: Received unexpected Report PDU1․3․6․1․6․3․15․1․1․1․0 [(usm StatsUnsupported SecLevels․0)]․ Walk stopped․"

SYMPTOMS:

  • The sapwalk2 utility drops the connection and reports an authorization error or security level mismatch

Environment

All supported versions

Cause

The "usmStatsUnsupportedSecLevels․0" error message indicates a security level mismatch between the request and the device configuration․

The Security Level provided in the command exceeds what the agent (the device) is configured to support or expect.

Resolution

1․ VERIFY DEVICE CONFIGURATION

Confirm if the problematic devices are configured for AuthPriv (Authentication and Privacy)

EXPECTED: Devices should have AuthPriv enabled NOTE: If devices are only configured for AuthNoPriv or NoAuthNoPriv, the sapwalk2 command using -l AP will continue to fail with the specific PDU error

 

2․ TEST LOWER SECURITY LEVELS

Run sapwalk2 with -l AnP (AuthNoPriv) or -l nAnP (NoAuthNoPriv) to see if the device responds

Command: ․/sapwalk2 -i [IP-address] -v v3 -l AnP -u [username] -xt SHA -xa '[password]' -xe AES128 -xp '[password]' -s 1․3․6․1 -t 5000 -r 5

EXPECTED: The sapwalk2 utility successfully walks the device without security level errors

 

3․ IMPLEMENT WORKAROUND

If SNMPv3 is misconfigured on the device side, switch the discovery profile to use SNMPv2c temporarily

EXPECTED: Devices are successfully discovered using SNMPv2c

 

4. VERIFY SUCCESS:

  • Devices respond to sapwalk2 without authorization errors

  • Devices are successfully discovered in DX NetOps