CP crashes randomly in UCUDB32 with 0xc0000005 with legacy agents
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CP crashes randomly in UCUDB32 with 0xc0000005 with legacy agents

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Article ID: 434456

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Following the upgrade from v21 to 24.4.3 or superior, the CP process where several Non-TLS Agents and CallAPIs connect to crashes.

On Windows, we may find some useful information about the potential cause as some minidumps are generated with this kind of errors:

Log Name:      Application
Source:        Application Error
Date:          06.03.2026 10:47:16
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:     server.domain.com
Description:
Faulting application name: UCsrvcp.exe, version: 24.4.3.1, time stamp: 0x69709356
Faulting module name: UCUDB32.dll, version: 24.4.3.1, time stamp: 0x697092e7
Exception code: 0xc0000005
Fault offset: 0x0000000000016902
Faulting process id: 0x236c
Faulting application start time: 0x01dcab3952174e54
Faulting application path: E:\Automic\AutomationEngine\bin\UCsrvcp.exe
Faulting module path: E:\Automic\AutomationEngine\bin\UCUDB32.dll
Report Id: 990ca8df-e740-42e8-85b5-b06cac11daf7

Log Name:      Application
Source:        Windows Error Reporting
Date:          06.03.2026 10:47:40
Event ID:      1001
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      server.domain.com
Description:
Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: UCsrvcp.exe
P2: 24.4.3.1
P3: 69709356
P4: UCUDB32.dll
P5: 24.4.3.1
P6: 697092e7
P7: c0000005
P8: 0000000000016902
P9: 
P10: 

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERF2CA.tmp.mdmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERF491.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERF4D0.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERF4DE.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERF54C.tmp.txt
\\?\C:\Windows\Temp\WER4B8D.tmp.appcompat.txt
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_UCsrvcp.exe_4ec2bad66f98dbf5f7f111a88a6b8dde6147af72_d142b207_cab_09164c74\memory.hdmp

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_UCsrvcp.exe_4ec2bad66f98dbf5f7f111a88a6b8dde6147af72_d142b207_cab_09164c74

 

On Unix, a core should be generated similarly when this occurs as the process ucsrvcp will exit with return code 11.

Environment

Automation Engine 24.4.3 and superior where CP process is started with some non-TLS agents are connected.

Cause

DE184204: incorrect buffer size on CP for messages coming from legacy agent causing the crash.

Resolution

Workaround 1 (in case Agents cannot be upgraded to a TLS version that connects to a JCP):

Install and configure a TLS Gateway as a CP Port with and connect the non-TLS agents that were connected to the CP that was crashing to it.รง

 

Workaround 2 (in case Agents can be upgraded to a TLS version like Agents Windows or Unix to 21.x or superior):

Upgrade the Agents to a TLS version that connects to the JCP.

 

Solution:

Update to a fix version listed below or a newer version if available.

Fix version:
Component(s): Automation Engine

Automation.Engine 24.4.4 HF1 - Available
Automation.Engine 24.4.5 - Planned release June 2026
Automation.Engine 26.0.0 HF1 - Planned release May 2026

Additional Information

Public Title: CP crashes when connecting to legacy Agents

Public Description: A problem has been fixed that prevents the CP from crashing when a legacy Agent is connected.