Manually created Resource Pools not visible in VCF Fleet Manager during node addition
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Manually created Resource Pools not visible in VCF Fleet Manager during node addition

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Article ID: 434308

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Adding a new VCF Operations node in VCF Operations using VCF Fleet Manager fails to list manually created Resource Pools.
  • Resource Pools are visible and confirmed in vCenter.
  • VMs (including vCenter) may have been migrated to the new Resource Pool via storage vMotion prior to node addition.

Environment

VCF Operations 9.x

Cause

The inventory of vCenter resources is not automatically in sync with VCF Fleet Manager after manual changes (creation, renaming, or moving) are made to Resource Pools in vCenter.

Resolution

To resolve this issue, perform a manual refresh of the data collection for the respective vCenter in VCF Operations:

  1. Log in to the VCF Operations UI.
  2. Navigate to Fleet Management > Lifecycle > VCF Management > Settings > Deployment Targets.
  3. Locate the vCenter where the Resource Pool changes were made.
  4. Click the Refresh Data Collection icon to synchronize the inventory.
  5. Retry the "Add Node" task in Fleet Manager for the VCF Operations component; the Resource Pool should now be visible.