Invalid: Virtual machine "###" is no longer protected. VM "###" is not replicated by VR. Protected VM deleted.
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Invalid: Virtual machine "###" is no longer protected. VM "###" is not replicated by VR. Protected VM deleted.

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Article ID: 434188

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • In VMware Live Recovery (VLR), a specific Virtual Machine displays an invalid state within a Protection Group. The VLR UI shows the following errors:

Error:

 Invalid: Virtual machine "VM_Name" is no longer protected. VM "VM_Name" is not replicated by VR. Protected VM deleted.

  • The VM remains healthy and powered on within the vCenter inventory, but the protection status fails to synchronize.

Environment

VMware Live Recovery 9.0.x

VMware vSphere Version: 8.0.U3

Cause

  • The VM Management Object ID (MOID) changes when the VM is removed and re-added to the vCenter inventory(following an inaccessibility event on an ESXi host). The vSphere Replication and SRM continue to reference the original MOID, which no longer exists in the current vCenter database.

The /opt/vmware/support/logs/srm/vmware-dr.log contains the following signature:

YYYY-MM-DDThh:mm:ss.ms+05:30 error vmware-dr[1759116] [SRM@6876 sub=Replication] Failed UnmarkVmAsSrmProtected op for vm vm-####:-> Referring to the old MOID
--> (vmodl.fault.ManagedObjectNotFound) {
-->    faultCause = (vmodl.MethodFault) null,
-->    faultMessage = <unset>,
-->    obj = 'vim.VirtualMachine:645343b1-8f43-4b39-9249-##########:vm-####'
-->    msg = "Received SOAP response fault from [<SSL(<io_obj p:0x00007fc62010f200, h:36, <TCP '<VR_Ip_Address> : 58880'>, <TCP '<VM_IP _Address> : 443'>>), /sdk>]: GetCustomValue
--> The object 'vim.VirtualMachine:vm-####' has already been deleted or has not been completely created"
--> }

Resolution

  • Follow the steps below to remove the invalid state VM from replication and re-add.

Here are the detailed steps :

  1. Log in to the VMware Live Recovery UI Client.

  2. Navigate to Protection Groups, select the affected group, and remove the invalid VM entry from the group and any associated Recovery Plans.

  3. Navigate to vSphere Replication > Monitor > Outgoing Replications.

  4. Select the affected VM and click Stop Replication. When prompted, ensure the option to keep target replica disks (seeds) is selected.

  5. In the vSphere Client, right-click the VM and select Site Recovery > Configure Replication.

  6. Follow the wizard to re-establish replication to the target site.

  7. At the Target Datastore selection, choose the folder where the previous replica disks reside.

  8. When the prompt appears regarding existing files, select Use as Seed.

  9. Complete the wizard and wait for the "Initial Sync" (Checksum Sync) to finish.

  10. Add the VM back into the original Protection Group and Recovery Plan.