Specific log files are missing when exporting ESXi host system logs from the vSphere Client
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Specific log files are missing when exporting ESXi host system logs from the vSphere Client

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Article ID: 434167

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • When exporting ESXi host system logs using the vSphere Client, specific log files are not found within the generated log bundle.
  • Missing log files include: 
    • /var/log/vmkernel.log
    • /var/log/hostd.log
    • /var/log/vpxa.log
    • /var/log/vmkwarning.log
    • /var/log/vmksummary.log
    • /vmfs/volumes/<datastore>/<vm-name>/vmware.log

  • This occurs when selecting only the "Base" option during the export process.

Environment

VMware vSphere ESXi
VMware vCenter Server

Cause

This behavior is by product design.
When a system log export is performed with only the "Base" option specified, various system log files stored in the ESXi host's scratch partition are excluded from the collection.

Resolution

To comprehensively collect the required log files, please generate the log bundle using the default settings without deselecting any options.

For detailed steps, refer to "Export System Log Files".

Additional Information

Japanese KB: vSphere Client から ESXi ホストのシステム ログをエクスポートする際、特定のログファイルが収集されない