CSA error Connection Unavailable - DB Connection failure08001
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CSA error Connection Unavailable - DB Connection failure08001

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Article ID: 434089

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

NSA / CSA service started returning the error Java.sql.SQLException: Connection unavailable after patching the server

  • sql.SQLException: Connection unavailable is thrown in nsa-system logs

Caused by: java.io.IOException: Connection timed out, socket connect lapse 131072 ms. /xxxxxx 1521 0 1 true

2026/03/10 07:06:21.338 | 07:06:21.271 [JGroups Heart Beat Monitor Thread] ERROR com.niku.union.persistence.PersistenceController - Exception due to DB Connection failure08001
2026/03/10 07:06:21.338 | java.sql.SQLException: Connection unavailable

Caused by: java.io.IOException: Connection timed out, socket connect lapse 131072 ms. /xxxxxx 1521 0 1 true

Environment

All Supported Clarity Releases 

Cause

Server connectivity issue

Resolution

Troubleshooting: 

  • Check nsa-system and nsa-ca logs for more information. 
  • Check in NSA if Status is set to Available on Database page
  • Check if database connection details still correct in NSA
  • Any IPs or hostnames changed?
  • Verify if you are able to ping the database server

This is typically an issue with connectivity / firewall - after ensuring all the details in Clarity CSA are correct, if you still see the issue, engage your IT team to verify firewalls and connectivity to fix this.