Error In Delta Sync Alarm observed in the NSX UI during an upgrade from 9.0.x to 9.1
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Error In Delta Sync Alarm observed in the NSX UI during an upgrade from 9.0.x to 9.1

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Article ID: 433929

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Updated On:

Products

VMware vDefend Firewall VMware vDefend Firewall with Advanced Threat Prevention

Issue/Introduction

When Identity Firewall (IDFW) is configured with at least one Active Directory (AD) domain, you may observe an "Error In Delta Sync Alarm" in the NSX UI after upgrading from version 9.0.x to 9.1.

Environment

NSX 9.0.x upgrading to NSX 9.1

Cause

The issue is caused by a database field change where the data type was updated. Specifically, a new field (highest_when_changed) was introduced to replace a deprecated field (max_when_changed), leading to a mismatch during the initial delta sync post-upgrade.

Resolution

A permanent fix for this issue will be available in an upcoming vDefend Firewall release.

Workaround

To resolve this issue and clear the alarm:

1. Log in to the NSX Manager UI
2. Navigate to System > Configuration > Identity Firewall AD
3. Locate the Active Directory Entry
4. Click the three vertical dots (ellipsis) icon on the far left of that row
5. A drop down menu will appear; select Sync All from the list. See the below image for reference


6. Once the sync completes successfully, the Delta Sync Alarm will clear automatically