Mobility Agent host showing disconnected in vCenter
search cancel

Mobility Agent host showing disconnected in vCenter

book

Article ID: 433892

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

Mobility Agent host disconnects from vCenter and displays the following error "Disconnected from host. Reason: Cannot verify the SSL trust"

Cause

This can be caused by the vCenter certificate not being updated within the HCX VAMI.

Resolution

  • Ensure that the correct certificate is imported into the HCX VAMI. 
  • For CA signed certificates this is the process for Importing Trusted Certificates from a Remote Site
  • After This is verified/completed re-register the vCenter with HCX and restart the App-engine and Web services.
  • Once that completes redeploy the IX appliance and ensure that the error is gone.  
  • If the issue persists then please open a Support Request with Broadcom and include the HCX Source and Destination bundles.