Set up VCF Identity Broker and VCF Logs in VMware Cloud Foundation 9.0
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Set up VCF Identity Broker and VCF Logs in VMware Cloud Foundation 9.0

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Article ID: 433807

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Updated On:

Products

VCF Automation

Issue/Introduction

  • After upgrading legacy VMware Aria 8.x components to VMware Cloud Foundation (VCF) 9.x, you must set up a new identity source. The legacy VMware Identity Manager (vIDM) is no longer supported in the new VCF 9.x architecture.
  • Additionally, you need to perform a new installation of VCF Logs because legacy VMware Aria Operations for Logs (formerly vRLI) 8.x does not have a direct upgrade path to VCF Logs 9.0.

Environment

 

  • VMware Cloud Foundation (VCF) Operations 9.0

  • VCF Identity Broker

  • VCF Logs 9.0

  • Legacy VMware Aria 8.x components

  • Legacy VMware Identity Manager (vIDM)

  • Legacy VMware Aria Operations for Logs (vRLI) 8.x

 

Cause

  • The legacy VMware Identity Manager is no longer supported for VCF 9.x deployments, requiring the enablement and configuration of the VCF Identity Broker. Furthermore, architectural changes mean that legacy VMware Aria Operations for Logs 8.x cannot be upgraded directly, necessitating a fresh installation of VCF Logs 9.0 from the Fleet Management console.

Resolution

To install VCF Logs and enable the VCF Identity Broker, follow these steps:

  1. Launch the VCF Operations 9.0 Console.

  2. Navigate to Fleet Management > Lifecycle > Management > Overview.

  3. To install VCF Logs, click Add under the VCF Logs section to go through the installation flow.

  4. To set up the new identity source, click Enable under the VCF Identity Broker section to go through the installation flow.