Resolve Platform Capacity Alerts for Application Discovery VMs by Constraining Scope in VCF Operations for Networks
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Resolve Platform Capacity Alerts for Application Discovery VMs by Constraining Scope in VCF Operations for Networks

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Article ID: 433795

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Updated On:

Products

VCF Operations for Networks

Issue/Introduction

A "Platform Capacity" critical alert is triggered. The system reports "System usage has breached the capacity" specifically for the "Application discovery VMs" metric as seen in the Infrastructure and Support screen like in the image below:

  • Platform Capacity UI shows Application discovery VMs usage exceeding the listed limit.

  • The environment contains more VMs than the listed capacity limit.

  • Application Discovery is attempting to process flows for the entire inventory or the scope is otherwise too wide, leading to a capacity breach.

 

Environment

VCF Operations for Networks

Cause

The Application Discovery feature is configured with a global scope across an inventory of VMs or the scope is not limited sufficiently so that the number of VMs in scope exceeds the Application Discovery VM capacity limit for the current node sizing and scenario.

Resolution

To resolve the capacity alert, modify the Application Discovery scope to a targeted subset of the inventory.

  1. Log in to the VCF Operations for Networks UI.

  2. Navigate to the Applications menu and select Application Discovery.

  3. Select the Flows tab and click Edit Discovery (or Modify Application Scope).

  4. Change the scope from the global inventory to a targeted subset by defining grouping criteria such as:

    • VM Names (Regex)

    • vCenter Tags

    • NSX Security Groups

    • Specific Clusters

  5. Save the configuration.

  6. Verify in the Platform Capacity UI that the "Application discovery VMs" usage has decreased below the threshold.

Additional Information

Modify Application Scope

System Recommendations and Requirements