Error "attempt to get token failed" when using UAAC to get a token for Ops Manager admin account
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Error "attempt to get token failed" when using UAAC to get a token for Ops Manager admin account

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Article ID: 433697

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Updated On:

Products

VMware Tanzu Platform - Cloud Foundry

Issue/Introduction

When trying to get a token for the admin user of Ops Manager, the following error is encountered:

$ uaac token owner get opsman -s ""
User name:  admin
Password:  ********************************

error response:
{
  "error": "invalid_client",
  "error_description": "The client is not authorized for any identity provider that supports password grant."
}
attempt to get token failed

Environment

Tanzu Operations Manager

VMware Tanzu Platform - Cloud Foundry

Cause

The Ops Manager UAA authentication was configured with SAML or OIDC Identity Provider.

Resolution

Use the following command instead to get the token.  It should prompt you for a Passcode.  Navigate to the URL that is given in the prompt to get the passcode, and then copy & paste that passcode into the prompt.

$ uaac token sso get opsman -s ""
Passcode (from https://opsmanager.example.com/uaa/passcode):