VMkernel Adapter Connectivity Failure Due to VLAN Pruning
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Article ID: 433667
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Updated On:
Products
VMware vSphere ESXi
Issue/Introduction
For some servers, configure private/non routable IP under same DVS, IP is not coming online.
Secondary VMkernel adapters (e.g., vmk1) fail to connect to the network, while the primary management interface (vmk0) connects successfully.
Traffic for the specific VLAN assigned to the secondary VMkernel adapter is dropped.
Connectivity is only restored when moving the affected VMkernel adapter to a newly created, secondary vSphere Distributed Switch (vDS).
Environment
VMware vSphere
Cause
VLAN pruning is enabled at the uplink portgroup level, and the required VLAN is missing from the allowed VLAN range.
The issue may intermittently occur across different host with different NIC vendors within the same cluster.
This is due to the setting not being supported by the NIC.
Resolution
Navigate to the vSphere Client.
Locate the affected vSphere Distributed Switch (vDS) and select the designated Uplink Portgroup.
Edit the Uplink Portgroup settings and navigate to the VLAN configuration.
Verify the allowed VLAN range.
Add the missing VLAN (e.g., VLAN 1501) to the allowed VLAN trunk range, or revert to the default range of 0-4094 to trunk all VLANs.
Validate that network traffic is now passing successfully for the secondary VMkernel adapter.
Migrate the affected VMkernel adapter from the secondary vDS back to the primary vDS.
Decommission the secondary vDS.
Additional Information
VLAN tags and modes can be set in several locations, including the portgroup of the vDS, the uplink port of the vDS, and the switchport of the upstream physical switch.
The main point is if VLAN pruning is used on the uplink profile, the expectation is that only the configured VLAN or range of VLAN will be allowed.
The setting is not always respected by the physical NIC.