USM portlet not opening with a popup error containing: Error communicating with HOST <PRIMARY HUB IP ADDRESS> on PORT 4334
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USM portlet not opening with a popup error containing: Error communicating with HOST <PRIMARY HUB IP ADDRESS> on PORT 4334

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Article ID: 43365

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The USM portlet fails to load and there is a popup error with:

An unknown error has occrred. 

Refreshing your browser...

Details: com.firehunter.ump.exceptions.DataFactoryException : Error communicating with HOST <PRIMARY HUB IP ADDRESS> on PORT 4334.

...

The discovery_server log also has error on this:

Retrying... : clojure.lang.ExceptionInfo: Error communicating with HOST <PRIMARY HUB IP ADDRESS> on PORT 4334 {:alt-host nil, :peer-version 2, :password "...", :username "...", :port 4334, :host "<PRIMARY HUB IP ADDRESS>", :version "0.9.5130", 

 


 

Additional Information:

If the truncating datomic_kvs does not resolve the problem follow the steps in this knowledge base document.

TEC000004861

How to reset discovery in CA UIM 8.10 or later 

Environment

Release: CNMSPP99000-8.4-Unified Infrastructure Mgmt-Server Pack-- On Prem
Component:

Cause

What's happening is the wasp probe cannot reach the udm_manager probe on the port that it listens on for Datomic connections(4334). Typically this is a result of a problem in the discovery information.

Resolution

1 deactivate the udm_manager and discovery_server probes


2 At the database run a query to truncate the datomic_kvs table.  

This example is for MS SQL Server using the default database name CA_UIM.

truncate table [CA_UIM].[dbo].[datomic_kvs]

2 activate the udm_manager and discovery_server probes.

Additional Information

If the truncating datomic_kvs does not resolve the problem follow the steps in this knowledge base document.

How to reset discovery in CA UIM 8.10 or later

https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=9544