Error: "Failure: Error downloading manifest. Please contact your vendor. Could not resolve host" occurs during repository check for upgrade
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Error: "Failure: Error downloading manifest. Please contact your vendor. Could not resolve host" occurs during repository check for upgrade

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Article ID: 433572

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • When trying to update vCloud online, you receive the error:

    "The address <hostname> is not resolving from any address; this address does not appear to be correct."
  • Upgrade of Cloud Director (VCD) fails.
  • When running the repository check you see an error like below:

    root@<cellname> [ ~ ]# vamicli update -- check
    Checking for available updates, this process can take a few minutes ...
    Failure: Error downloading manifest. Please contact your vendor. Could not resolve host: vapp-updates.vmware.com URL: https://vapp-updates.vmware.com/vai-catalog/valm/vmw/7490b80d-eb6e-4b94-b2a4-23c06a81679d/10.6.1.11883.latest/manifest/manifest-latest.xml

  • Unable to connect to vapp-updates.vmware.com with curl on port 443.

Environment

VMware Cloud Director 10.6.1

Cause

Broadcom has migrated VMware product updates from vapp-updates.vmware.com to dl.broadcom.com.

Resolution

To resolve this issue follow the instructions outlined in how to Upgrade Your VMware Cloud Director Appliance by Using the VMware Update Repository.

Additionally ensure that the Cloud Director cells can reach the address dl.broadcom.com through any environmental firewall.