VCF Operations for Logs UI is not available after upgrade to 9.0.2
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VCF Operations for Logs UI is not available after upgrade to 9.0.2

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Article ID: 433517

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Updated On:

Products

VCF Operations

Issue/Introduction

  • VCF Ops for Logs seems broken
  • Fleet manager shows it installed and updated to 9.0.2
  • The main IP address pings, but https connections cannot be established

Environment

VCF Operations for Logs 9.0.x

Cause

The /storage/var partition is 100% utilized due to the presence of heapdump file(s).

VCF Operations for Logs is configured to create a heapdump file when the service crashes. The /storage/var partition is limited in size and the heapdump file typically exceeds the capacity of the partition. The resulting heapdump file is corrupted and must be removed.

Resolution

  1. Take snapshots of all nodes in the VCF Operations for Logs cluster (How to take a Snapshot of Operations for Logs)

  2. Log in to the affected VCF Operations for Logs node as root via SSH or vSphere console

  3. Validate that the /storage/var partition is 100% utilized

    df -h /storage/var

     

  4. Validate that there is a large amount of space used in the heapdump directory

    du -hd1 /storage/var/loginsight/heapdump/

     

  5. Identify the heapdump file(s) that will be removed

    ls -l /storage/var/loginsight/heapdump/*.hprof

     

  6. Remove the heapdump file(s) from the system.

    rm /storage/var/loginsight/heapdump/*.hprof

     

  7. Reboot the node

    reboot -f

     

  8. Repeat steps 2-7 for any remaining VCF Operations for logs nodes that are affected

Additional Information

VCF Operations for Logs UI is not available after upgrade to 9.0.2