Cannot login to WCC after upgrade of EEM from 12.6.4.0 to 12.7.2.0, "Login failed. The EEM is down"
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Cannot login to WCC after upgrade of EEM from 12.6.4.0 to 12.7.2.0, "Login failed. The EEM is down"

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Article ID: 433423

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

After performing an successful upgrade of EEM to 12.7.2.0,  cannot work with EEM anymore.  In the CA-wcc.log, there are errors like:

"WARN #EEMStatusCheck                     # Cannot ping the EEM backend ."

 

Cause

WCC certificate with in EEM needs to be re-issued

Resolution

Follow below approach to reissue WCC certificates on the WCC Server:

On Unix/Linux:

cd $CA_WCC_INSTALL_LOCATION/safex
./safex -h <eem_host.example.com> -u EiamAdmin -p <password> -f IssueCertificate.xml
cp -p wcc.* $CA_WCC_INSTALL_LOCATION/data/config/
unisrvcntr stop CA-wcc-services
unisrvcntr start CA-wcc

On Windows, open a Command Prompt as Administrator:

cd %CA_WCC_INSTALL_LOCATION%/safex
safex.bat -h <eem_host.example.com> -u EiamAdmin -p <password> -f IssueCertificate.xml
copy -p wcc.* %CA_WCC_INSTALL_LOCATION%\data\config

Stop and Start the CA-wcc-services service from Windows Services Control Panel