vAPI Endpoint service health alarm is triggered immediately after vCenter Server update
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vAPI Endpoint service health alarm is triggered immediately after vCenter Server update

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Article ID: 433383

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Immediately after performing a vCenter Server update or a system reboot, alarm triggered 'vapi-endpoint status changed from green to yellow'
  • /var/log/vmware/vapi/endpoint/endpoint.log shows Error similar with
    YYYY-MM-DDThh:mm:ss.xxxZ | ERROR | state-manager1            | SoapBindingImpl                |                                      | Error communicating to the remote server http://localhost:1080/sts/system-STSService
    com.sun.xml.internal.ws.client.ClientTransportException: The server sent HTTP status code 503: Service Unavailable
    :
    YYYY-MM-DDThh:mm:ss.xxxZ | INFO  | state-manager1            | HealthStatusCollectorImpl      |                                      | Computed health status is ORANGE.
    

Environment

VMware vCenter Server 8.x

Cause

This issue occurs because the vapi-endpoint service cannot access the STS (Security Token Service) while the STS service is still initializing immediately after a vCenter Server update or reboot.
This is a temporary state caused by the sequential startup process of vCenter Server services, which leads the vapi-endpoint service to temporarily report its health status as a warning.

Resolution

This behavior is a temporary, expected noise inherent to the vCenter Server architecture. It has no actual impact on the system or operations.
The corresponding alarm displayed in the vSphere Client can be safely ignored.

The alarm will automatically return to Green after both the STS service and the vapi-endpoint service are fully initialized and running.